UpgradeUbuntuFromEOS?

gutsy already reached end-of-life

  • Ubuntu 7.10(Gutsy Gibbon)がサポート終了。
    • 2009/4以降はセキュリティアップデートが提供されない
  • サポート収量とともに、aptリポジトリが消失
    • つまり、通常のインストールも不可能。

ライフサイクルについて

デスクトップおよびサーバーの無償セキュリティアップデートが、少なくとも18ヶ月間に渡って提供されます。長期サポート(LTS)版を利用すれば、デスクトップについては3年間、サーバーについては5年間に渡り提供されます。

  • http://www.ubuntulinux.jp/products/WhatIsUbuntu
  • その他のサポート期間
    コードネームバージョンリリース日サポート期限
    Intrepid Ibex8.102008年10月30日2010年4月
    Hardy Heron8.04 LTS2008年4月24日2011年4月(デスクトップ)/2013年4月(サーバ)
    Dapper Drake6.06 LTS2006年6月1日2009年6月(デスクトップ)/2011年6月(サーバ)

Ubuntu 8.04LTS(Hardy)へのバージョンアップ

  • このままでは色々問題なので、LTSへバージョンアップを図る。

old-releasesリポジトリへ移行

まずはhttp://archive.ubuntu.com/ubuntuからいなくなったgutsyリポジトリの復活を行う。

  1. aptのリポジトリを修正
    • /etc/apt/sources.listの内容を下記に置き換える。
      deb http://old-releases.ubuntu.com/ubuntu/ gutsy main restricted universe multiverse
      deb http://old-releases.ubuntu.com/ubuntu/ gutsy-updates main restricted universe multiverse
      deb http://old-releases.ubuntu.com/ubuntu/ gutsy-security main restricted universe multiverse
  2. gutsyを最新の状態へアップグレード
    • リポジトリ情報更新
      sudo apt-get update
    • アップデート
      sudo apt-get upgrade
  • 重要!!:ここまでの処理で取り合えずは、リポジトリが利用できるようになる。

upgrade

注意!!:アップグレードは成功するとは限らないため、バックアップ等最悪の自体に備えておくこと

  1. アップグレードマネージャのインストール
    sudo aptitude install update-manager-core
  2. リポジトリ修正
    • 重要!!:/etc/apt/sources.listの内容を下記に置き換える。
      # コメントアウト
      #deb http://old-releases.ubuntu.com/ubuntu/ gutsy main restricted universe multiverse
      #deb http://old-releases.ubuntu.com/ubuntu/ gutsy-updates main restricted universe multiverse
      #deb http://old-releases.ubuntu.com/ubuntu/ gutsy-security main restricted universe multiverse
      #archiveリポジトリ
      deb http://archive.ubuntu.com/ubuntu/ gutsy main restricted universe multiverse
      deb http://archive.ubuntu.com/ubuntu/ gutsy-updates main restricted universe multiverse
      deb http://archive.ubuntu.com/ubuntu/ gutsy-security main restricted universe multiverse
      • アップグレードツールはディストリ名であるgutsyの部分をhardyへ書き換えてアップグレードを実施するが、old-releasesリポジトリにはhardyが存在しないため失敗する。
  3. アップグレード実行
    sudo do-release-upgrade
    • 後は画面の指示にしたがってアップグレードを進めていく、サーバなので日本国内なら30分程度の作業

参考


リロード   新規 編集 凍結 差分 添付 複製 改名   トップ 一覧 検索 最終更新 バックアップ   ヘルプ   最終更新のRSS
Last-modified: 2010-03-14 (日) 07:00:26 (2628d)